Results 1 to 4 of 4
  1. #1

    Star Wars - The Old Republic

    I'm playing a Sith Sorcerer in the game thats only lvl 20 yet, so i don't know how well this works out for higher level characters or other classes. But so far for me its fun to use, so feel free to use this to work out your own configurations.

    Right Controler:
    Up = 1

    Button 4 + left controler gestures:
    4+up = Map
    4+left = Character
    4+right = Inventory
    4+Down = Questlog
    4+ccw = Crew
    4+cw = Sozial

    Left Controler: (lmb= left mouse button)
    Joystickbutton=TAB (targetswitch)
    Bumper=Left Mousebutton
    Trigger=Right Mousebutton
    1=lmb, delay, num_1
    2=lmb, delay, num_2
    3=lmb, delay, num_3
    4=lmb, delay, num_4
    Start=lmb, delay, num_5

    Tilt up=jump
    Tilt down=autorun (remapped to num_* or it would also switch numpad on+off all the time)
    Tilt ccw=zoom out
    Tilt cw=zoom in
    Tilt left=9
    Tilt right=10

    In the game i mapped the 2nd Bar shift+1-10 and a third bar with one half num_1-num_5 and one half shift+num_1-shift+num_5.
    Also i remapped shift+scrollwheel to alt+scrollwheel or it could accidentaly switch the bars, and Autorun from num_lock to num_* so it doesn't toggle the numberkeys.

    On the Numberkeys i use skills that suit well for mouseover usage, like heals, buffs, cc. The Hydra does the leftclick on those, so just point at it, fire&forget.

    When i tried, it didn't work using the beta driver, but works well for the 1.01 razer driver.

    Stuff for scripting geeks to do: have the right mouseclick toggle to fps mode while clicked and back to wand mode after release (to sick of xml/mce right now again)
    Attached Files Attached Files

  2. #2

    Re: Star Wars - The Old Republic

    Looks like some good work. I cant get the game to work with this or any mce though.
    hydra working fine in windows but then the game starts and its 100% dead

    Do you know if SWTOR blocks the hydra software because it thinks its some sort of scripting hack?


  3. #3

    Re: Star Wars - The Old Republic

    For me it works only using the razer 1.01 driver, and the hydra's app has to be run with Administrator rights.

  4. #4

    Re: Star Wars - The Old Republic

    Ah awesome! Thanks for the help. Running on admin fixed it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT -8. The time now is 12:50 AM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
vBulletin Skin By: